HtmlEditor :  Phorum 5 The fastest message board... ever.

This is the discussion forum for the HtmlEditor. See also the HtmlEditor home page, where you can download the control, and the Documentation Wiki, a collaborative project for documenting the control.

Goto Thread: PreviousNext
Goto: Forum ListMessage ListNew TopicSearchLog In
Capturing Focus Issue (Again)
Posted by: James Robert Hancock (---.darwinconsulting.com)
Date: Thursday, 13-Nov-2003, 18:04:25

Ok, so here's the problem as we know it. When the control is created on a form, the HTML Editor surface (NOT the HTML Editor itself) gets the focus and the caret is displayed.

Further, if the HTML Editor is on a tab and you click into a control that isn't on the tab, the HTML Editor never loses focus and you can continue to type.

At this time, .net reports that the form's active control is NOT the HTML Editor, but the control you clicked on, even though you get these weird results with the HTMLEditor and typing.

The core problem here seems to be a windows bug, but there has to be a way around it. Anyone have any ideas? This is the last critical bug that I can't work around and it's driving me nuts.

Re: Capturing Focus Issue (Again)
Posted by: James Robert Hancock (---.darwinconsulting.com)
Date: Friday, 28-Nov-2003, 21:11:04

I've finally fixed this once and for all. Tim as the latest code from me that fixes this problem. It's a non-trivial fix (it's a hack really for a bug in the Stream Loading functions from MS) but it gets the job done. *Phew*

Re: Capturing Focus Issue (Again)
Posted by: Jeff Evans (64.39.170.---)
Date: Tuesday, 09-Dec-2003, 16:34:01

James / Tim,


I've been following this control for a few weeks ago, and was going to take a stab at fixing the 'focus' issue, but it sounds like you've already done this -- is the updated code available to try out yet?


Thanks,


Jeff Evans.

Re: Capturing Focus Issue (Again)
Posted by: James Hancock (---.darwinconsulting.com)
Date: Thursday, 11-Dec-2003, 04:41:15

My solution is a hack. If you want to try a really good way of fixing the LoadDocument and LoadURL methods getting partial focus (i.e. a cursor) on load, I would be enternally greatful!



Your Name: 
Your Email: 
Subject: 
Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically.
yeepb
This is a moderated forum. Your message will remain hidden until it has been approved by a moderator or administrator
This forum powered by Phorum.