HtmlEditor :  Phorum 5 The fastest message board... ever.

This is the discussion forum for the HtmlEditor. See also the HtmlEditor home page, where you can download the control, and the Documentation Wiki, a collaborative project for documenting the control.

Goto Thread: PreviousNext
Goto: Forum ListMessage ListNew TopicSearchLog In
Hide/Show window problem
Posted by: Cristiano (---.sisgraph.com.br)
Date: Thursday, 25-Mar-2004, 14:13:34

Hi.

I'm using the Jamie Hancock's version of the control becouse I had problems with focus on forms.

Now, when I use a Form.Hide and then a Form.Show, the control just disappear, it becomes disable without any contents.

Does anybody know a solution?

Thanks.

Re: Hide/Show window problem
Posted by: James Hancock (---.darwinconsulting.com)
Date: Wednesday, 07-Apr-2004, 04:24:48

Hrm. I'm not seeing it with my version I have here (highly modified with toolbars etc...)

I'll see if I can find anything that would cause this.

Re: Hide/Show window problem
Posted by: Robert Palmer (194.205.123.---)
Date: Tuesday, 04-May-2004, 14:33:21

I have the same problem.
As additional information I am wrapping the mshtml control as a c#control ( Inheriting System.Windows.Forms.UserControl ).
Furthermore when the .LoadDocument(html) method is called the html is not rendered on the control.

Do you have any advice.
Thanks

Re: Hide/Show window problem
Posted by: Ghanashyam (203.200.200.---)
Date: Thursday, 29-Jul-2004, 09:07:51

I am having a similar kind of problem. I wrap an ActiveX control in c# user control and this user control is placed on a form. When the form is hidden and shown back, the ActiveX control everytime gets a WM_CREATE message, while I had expected it to get it only once. Hiding the form should not destroy the window I guess, but somehow it seems its doing that. The ActiveX control does not get a WM_DESTROY event but gets a WM_NCDESTROY event. Any clues on whats happening? and how I can resolve this?

Re: Hide/Show window problem
Posted by: James Hancock (---.darwinconsulting.com)
Date: Tuesday, 10-Aug-2004, 01:49:42

Robert:

Your problem is most likely the UserControl... I've had all kinds of issues with user controls and the html editor. Hence why I've put everything that was on my user control into the main control (toolbars etc)



Your Name: 
Your Email: 
Subject: 
Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically.
mN7K3
This is a moderated forum. Your message will remain hidden until it has been approved by a moderator or administrator
This forum powered by Phorum.