Another pro musician gives up on Vista audio

I occasionally highlight interesting comments to this blog, because they are less visible than new posts. This one for example:

After months of struggling with Vista, I have now completely removed it from my quad-core, purpose-built audio recording PC. With all the same hardware, XP 64 bit edition is working as I had hoped Vista 64 would. The machine now records and plays back flawlessly.

The question I originally posed was whether Vista audio problems are primarily to do with poor drivers, or indicate more fundamental problems. Initially I was inclined to blame the drivers, especially as Microsoft put a lot of effort into improving Vista’s audio. However, read this post by Larry Osterman. He mentions three problems with audio in XP, and says:

Back in 2002, we decided to make a big bet on Audio for Vista and we committed to fixing all three of the problems listed above.

However, only one of his three problems is unequivocally about improving audio. The first is actually about Windows reliability:

The amount of code that runs in the kernel (coupled with buggy device drivers) causes the audio stack to be one of the leading causes of Windows reliability problems.

Therefore, Microsoft moved the audio stack:

The first (and biggest) change we made was to move the entire audio stack out of the kernel and into user mode.

though he adds that

In Vista and beyond, the only kernel mode drivers for audio are the actual audio drivers (and portcls.sys, the high level audio port driver).

So, not quite the entire audio stack. Some pro musicians reckon the removal of the audio stack from the kernel is the reason for Vista’s audio problems.

However you look at it, it is to my mind a depressing failure that a year after Vista’s release you can find pro musicians giving up, and even vendors (who have an interest in Vista working properly) making comments like this one from Cakewalk’s Noel Borthwick:

Vista X64 (and X86 to some extent as well) is known to have inherent problems with low latency audio. We have been in touch with Microsoft about this and other problems for over a year now so its not that Cakewalk hasn’t done their bit. There are open case numbers with MS for this issue as well.

It does look as if, for all the talk of “a big bet on audio in Vista”, Microsoft does not care that much about this aspect of the operating system.

Anyone tried audio in Vista SP1 yet?

Technorati tags: , ,

Page 1 of 2 | Next page

Related posts:

  1. Unravelling the reasons for Vista audio glitches
  2. Audio in Vista: more hell than heaven
  3. Why does audio glitch in Vista?
  4. A musician speaks out to defend Oink
  5. Performance: Windows 7 fast than Vista, Vista faster than XP