Vista display driver takes a break

I’m seeing an annoying error on my Portege M400 running Vista. The thing is almost clear of beta drivers now, after numerous downloads from Toshiba, including the display driver. The graphics chipset is a Mobile Intel 945GM, and I have a production release driver dated 13th December 2006, version 7.14.10.1151, though I saw the same problem with earlier releases.

Specifically, from time to time the display blanks out and an error 4101 is logged. Sometimes I get this supposedly reassuring toast pop-up:

The warning message is:

Display driver igfx stopped responding and has successfully recovered

The error is worse than it sounds. The screen blanking is irritating, and sometimes causes the current application to crash (I’ve seen this with games). I’ve also seen it when working with multiple displays. Fortunately it only seems to occur with the display is being stressed in some way – I can work all day in Word and Excel, and not see the problem.

I’ve tried turning off Aero and it makes no difference.

A bug in Intel’s driver I suppose (I never get this on my Vista desktop), though it is not exclusive to Intel; this user reports the same problem with a GeForce 7900.

This is the kind of thing that spoils Vista right now. I think this OS will work much better six months from now.

Technorati tags: , ,

289 thoughts on “Vista display driver takes a break”

  1. its 2008 now and i dont think i can download the 7.14.10.1187 driver anymore ive looked al over for it. I read on the WoW forums that installing that version will fix the screen blacking. Anyone know where i can find it? At the moment i have 7.14.10.1318 installed and i am currently in VGA mode as i write this. What do i do? please anyone help if you can! any help at all will be greatly appreciated. thanx for your time.

  2. OH i forgot to mention my card type…

    Mobile Intel(R)965 Express Chipset Family

    and i have a HP Compaq Presario C700 laptop

    thanx again.

  3. YAY! indeed Premo the 15.4.4 driver un update worked for my ‘Mobile Intel(R)965 Express Chipset Family’ and im 85% sure i can play WoW without the black screens of doom on 85& bcoz i got disconnected from the private server… ah the price u pay for free stuff.

    THANKS TIM! U ROCK!

  4. Hi Tim,

    I had the same issues and read through all of those comments until somebody mentioned a driver. Nothing until this point had worked. Duh! So I went to update my driver (which is another long handed experience) and yai, I got it!

    People, if you have problems check your drivers first. I learned this from this discussion.

  5. 15.4.4? the link is no longer avaliable 🙁 im downloading 15.11.3.1576 (7.15.10.15.76) do u know if this works? ‘Mobile Intel(R)965 Express Chipset Family’ too!

  6. You could try (for Vista) shifting the Priority in Task Manager for igfxsrvc.exe up to “Realtime” and then (if you have a Duo core) Set Affinity for your game process (i.e. WoW) to CPU 0 and igfxsrvc to CPU 1. If you’re really having problems, move other programs which take up a lot of memory away from CPU 1 (uncheck CPU 1 for those) and then the igfx service module will get as much processor attention as it needs. I don’t know for sure if this works because my errors are totally at random. I guess there is always a way to overload this process; depending on how much stress you put on the video card as previously mentioned.

    Hope you find your answer, even if I can’t give it! I’m sorta looking for an answer too since this error nuked Cabal for me. -.-

  7. I have the 945G Intel chipset. I purchased this computer shortly after Vista’s launch and didn’t have a choice in whether or not to get a comp with Vista on it.

    I’m getting increasingly frustrated. I’ve tried manually updating the driver – it says I already HAVE the “best driver for me” (freaking creepy Vista). I tried the service patch provided on Microsoft’s site and it says “this is not for your system” after going to the trouble of downloading their verification software and all that. Naturally, tech support from them would cost me an arm and a leg.

    The only other option I have is the uninstall, reinstall driver bit. I get the blank screen when playing Perfect World, and even MORE when playin SimCity 4 – an extremely old game that should have no trouble running on this computer. It will repeatedly restart the video driver and finally crash.

    I don’t know what the “reboot shortcut” is and am afraid to try it. Anyone know of any other solution?

    Thanks.

  8. I just started having the same problem a couple days ago. I’ve had my laptop almost a year and never seen this problem. I don’t play games on my laptop. I get this error msg when simply browsing the Web or doing my online classes. It’s really frustrating. Is there anything I ca do to fix this yet? I see msg back to ’07. Someone let me know if there is a fix.
    snowangel_8869@yahoo.com. make sure the subject says something about this or it will get deleted. Thanks and have a good day all.

  9. OK, this is kinda odd but I was going through files installed with Spore (readme’s and stuff) and I come across the intel driver downloads link so i go to this website and install it and ever since i’ve installed it, this has been happening. I don’t know if this has happened before, but i don’t want to read through 260 posts.

    I see a lot of stuff like 945GM and stuff. I’m not sure if i have it or not, because all i can find is: Mobile Intel(R)4 Series Express Chipset Family

  10. i have the same problem but i ignored not only with the games but with hd movies same thing i ignored and new i have a hardwere roblem n more laptop is dead is a hp broth from uk uith nvidia dedicated 256 mb it was 1200 pounds at that time and new is dust

  11. I’ve read all 263 posts in this thread. I have a brand new HP laptop. My old HP was running NVidia, and it crashed a few weeks ago. HP says that it’s out of warranty, and wanted several hundred dollars to fix the problem, plus shipping and insurance. I opted to purchase a new system instead. I had been getting the display error every now and then on the old laptop (running Vista), but not often, and there was no pattern to it. Now on my new lap top, I get the message at least every 15 minutes, sometimes more often. I don’t get it when I’m playing games, or on Second Life. I get it when I’m typing papers in Word, or on my school’s website. Not a good deal for an on-line student. I have copied out the fixes mentioned. I’m not at all computer savvy, and as the fixes are almost two years old, I don’t know if they will work. I don’t know what my chip set is, and I don’t know how to find out. The only thing that I know for sure is that I’m not running an NVidia card in this lap top. The sticker on my computer says Intel Graphics Media Accelerator 4500MHD, and I think that might be talking about the video card, but I’m not sure.
    As I just purchased the computer last week at Sam’s Club, I have the option of taking it back and exchanging for a Vista 64 bit OS.
    Thanks for taking the time to help.

  12. I just bought a Dell desktop with built in intel chip set and connected two monitors. I applied all windows updates and patches required including the Vista SP2 64bit version. I am getting this error and I went Intel website and used its utility to update my driver as well. I seem to have all the latest drivers and software and the machine has 3GB memory and about 150MB is currently used by the graphics card.

    Product Detected Intel® G43/G45
    Current Driver Installed 7.15.10.1688

    Can any one recommend a fix for this problem?

    Thanks
    Ik.

  13. yes the same thing happens to me i play my game sims3 and it keeps messing up the graphics and so i minimize the game and it says it has recovered then when i go back on the game it keeps doing it unti lit shuts down my whole entire computer im geting so pissed off…. does anyone know how to fix it?

  14. I am getting the same thing on Sims 3. Only when i use a computer so far though. It was ok at first. just annoying to wait for it to recover. But when i go from playing a video game (in sims 3) to talking to people on the computer it can’t recover and crashes the comp.

  15. I have a dell inspiron, and I’m not a computer genius, however I’m pretty decent at following instructions and fixing my computer to the best of my ability on my own. On top of already frusterating computer problems (My computer has 1GB of memory left even though I uninstalled unused programs, and deleted my music and pictures.) I now can’t play Sims 3 because of my display driver. Is there any relatively simple way to fix this nuisance!?

  16. I have just bought the SONY VAIO VGN-TT21WN and I have the same problem: while working with word and the web at the same time my screen goes black. I am getting crazy. Zoe from Greece.

  17. @Katie, @Zoe, if it is the same issue it is a driver problem. First step is to get latest drivers from the vendor site for your computer.

    Tim

  18. I have an Ubuntu CD that I haven’t switched to yet… looks like I have yet another good reason to switch from Vista to Linux. Whee!

  19. 3 years and counting and still no fix

    this is still coming out on brand spanking new pcs and i believe it has to do with Vista as I’ve never encountered this on my XP machines…

  20. I’ve got it and it happens when I’m playing TF2 (Team Fortress 2) and whenever it happens i keep dieing from other people killing me, and im on a a Dell Inspiron 1525(don’t get Dells, they suck), had it for about a year.

Leave a Reply

Your email address will not be published. Required fields are marked *